2009年05月06日

opensslをインストール


> no such file to load -- openssl (RuntimeError)

というエラーが出てなんだろうかと思ったら、opensslが入ってないっぽい。

> cd rubyソースのディレクトリ/ext/openssl
> sudo apt-get install openssl
> sudo apt-get install libssl-dev
> sudo ruby extconf.rb
> sudo make
> sudo make install

インストール確認で、

> irb
> require 'openssl'
> => true

と表示されればOK。


ラベル:ubuntu openssl
posted by purigen at 16:27| Comment(0) | TrackBack(0) | Ruby | このブログの読者になる | 更新情報をチェックする

2009年05月05日

gem uninstall 失敗


> sudo gem list

で表示されているモジュールをアンインストールしようと思って、

> sudo gem uninstall ******

とやったら、

> ERROR: While executing gem ... (Gem::InstallError)
> Unknown gem ***** >= 0

とかエラーが出てしまう。なんでだろう?っと思って調べたら、
該当のモジュールが「/home/ユーザー名/.gem/ruby/1.9.1」に入ってた。

> gem env
> - GEM PATHS:
> - /usr/local/lib/ruby/gems/1.9.1
> - /home/ユーザー名/.gem/ruby/1.9.1

とGEM PATHSが二つございますね・・・。 どうも、権限の問題で、

> sudo gem install *****

とやると「/usr/local/lib/ruby/gems/1.9.1」にインストールされて、

> gem install *****

とやると「/home/ユーザー名/.gem/ruby/1.9.1」にインストールされるもよう。
Ubuntuで何かする時は、sudoをちゃんとつけましょうと・・・。


> sudo gem uninstall -i /home/ユーザー名/.gem/ruby/1.9.1/ *****

とやるとアンインストール成功します。
ラベル:Gems
posted by purigen at 15:06| Comment(0) | TrackBack(0) | Ruby | このブログの読者になる | 更新情報をチェックする

2009年05月04日

Aptana Plugin EclipseをインストールonUbuntu

ほんとはAptanaを入れたかったんだけど、変なエラーが出るので
とりあえず、Eclipse pluginとして入れてみようかと。

1.Java仮想マシーンをインストール
 EclipseがJava仮想マシーン上で動作するので、Java仮想マシーンをインストールする
 必要があります。
 

> sudo apt-get install sun-java6-jdk
 

2.Eclipseをインストール
 Eclipse公式から、「Eclipse IDE for Java EE Developers」をダウンロードしてくる。
 ダウンロードが終わったら、解凍して終わり。

3.Aptanaを入れる
 解凍した中にあるEclipseを実行して、
 
  「Help>Software Updates」

 をクリック。「Available Softwareタブ」を選択して、「Add Site...」をクリック。
 ウィンドウが出てくるので、

  Location:[http://update.aptana.com/update/studio/3.4/]

 と入力すると、Aptanaが出てくるので、後はNextとかInstallとかボタンを押してけばOK。

4.RadRailsを入れる
 3.と同じ要領で「http://update.aptana.com/update/rails/3.2」のインストールを行う。

参考:
Eclipse Pluginの設定方法が書いてある(英語)
ラベル:Aptana Eclipse
posted by purigen at 02:04| Comment(0) | TrackBack(0) | Ruby | このブログの読者になる | 更新情報をチェックする
×

この広告は180日以上新しい記事の投稿がないブログに表示されております。